Guida per l'utente
Nitro PDF Mac

Creazione di moduli

(Funzionalità avanzata di PDFpenPro)

Con PDFpenPro puoi creare un modulo PDF interattivo da compilare con la possibilità di inviare i dati via web o e-mail. PDFpenPro può anche creare automaticamente campi modulo e caselle di controllo in un modulo statico. (È supportato un modulo per documento PDF.)

Quando crei un modulo, potresti voler progettare il layout in un'altra applicazione per il miglior layout, quindi stampare quel documento in PDF e utilizzare PDFpenPro per aggiungere i campi del modulo interattivi.

Aggiungi automaticamente campi modulo e caselle di controllo a moduli PDF statici

PDFpenPro può scansionare un modulo statico e aggiungere campi interattivi per te.

  1. Apri un modulo PDF con campi statici. Vai a Modifica > Crea campi modulo...
  2. Viene visualizzata la finestra di dialogo Crea campi modulo automaticamente, fare clic su OK.
  3. Viene visualizzata una barra di avanzamento mentre l'applicazione rileva i campi di testo e le caselle di controllo del modulo. Un segnale acustico indica il completamento.

Noterai che tutti i campi sono evidenziati in grigio per indicare la loro posizione. Si attiva automaticamente quando i campi vengono resi attivi. Puoi disattivarlo scegliendo Visualizza > Evidenzia campi modulo.

Aggiunta manuale di elementi del modulo

  1. Fare clic sulla freccia giù accanto al pulsante Modulo
    toolbar-form-tools
    nella barra degli strumenti.
  2. Scegli l'elemento del modulo che desideri aggiungere.
  3. Fare clic nel PDF per aggiungere l'elemento. Trascina le maniglie d'angolo dell'elemento selezionato per creare la dimensione e la forma desiderate. Per assistenza nel posizionamento dei tuoi elementi, vai su Impostazioni > Allineamento
    allineamento degli ispettori
    . ( Ispettore ).
  4. Scegli Impostazioni > Proprietà elemento modulo
    inspector-form-elements-properties- 1
    per impostare le proprietà di ogni elemento del modulo.
Salva i campi modulo utilizzati di frequente nella Libreria
libreria degli strumenti
. La prossima volta che vuoi utilizzare i campi del modulo, trascinalo dalla Libreria sulla pagina. ( Biblioteca ).

Elementi del modulo

Per aggiungere qualsiasi elemento del modulo, fai clic sullo strumento per attivarlo, quindi fai clic sulla pagina del documento per aggiungere l'elemento. Fare clic e trascinare per impostare una dimensione personalizzata per l'elemento.

strumento campo di testo

Campo di testo L'area del modulo che consente l'immissione di dati univoci. Quando aggiungi un campo di testo, puoi fare clic e trascinare per ottenere la dimensione del campo desiderata.

strumento casella di controllo modulo

Casella di controllo Utilizzata per una o più opzioni, alcune o tutte selezionabili. Quando si aggiungono caselle di controllo, PDFpenPro aggiunge automaticamente un'etichetta di testo accanto all'elemento che può essere selezionato separatamente e ridimensionato, spostato o eliminato. Scegli un'opzione di visualizzazione in Proprietà elemento modulo.

form-radio-tool

Pulsante di opzione Utilizzato per un gruppo di opzioni in cui è possibile selezionarne solo una. Quando si aggiungono pulsanti di opzione, PDFpenPro aggiunge automaticamente un'etichetta di testo accanto all'elemento che può essere selezionato separatamente e ridimensionato, spostato o eliminato. Scegli un'opzione di visualizzazione in Proprietà elemento modulo.

strumento di scelta della forma

Campo di scelta Utilizzato per creare un menu a discesa di opzioni selezionabili. Aggiungi e rimuovi opzioni tramite le proprietà degli elementi del modulo (sotto).

strumento elenco moduli

Campo elenco Utilizzato per creare un gruppo di opzioni selezionabili. Aggiungi e rimuovi opzioni tramite le proprietà dell'elemento modulo (vedi sotto).

campo firma

Campo firma Aggiungi un campo firma interattivo che aiuta nella firma di un modulo. Fare clic e trascinare per selezionare la dimensione e la posizione del campo. Un timbro "Firma qui" apparirà nell'angolo in alto a destra del campo. Per i dettagli su come agisce il campo, vedere Utilizzo di un campo firma interattivo .

strumento di invio modulo

Pulsante Invia Utilizzato per aggiungere un pulsante al modulo per inviare i dati del modulo tramite e-mail o Web. Quando si aggiunge il pulsante, si aprirà una finestra di dialogo che consente di inserire un URL di destinazione o un indirizzo e-mail a cui inviare i dati.

Per ulteriori informazioni sull'invio dei moduli, vedere Elaborazione dei dati dei moduli .

Testare il modulo e modificare l'aspetto

Dovrai passare allo strumento Seleziona testo
strumento di selezione del testo
(Comando+ 1 ) per provare il tuo modulo. Torna allo strumento Modifica
strumento di modifica
(Comando+ 2 ) per modificare l'aspetto degli elementi che hai inserito nel modulo.

Proprietà dell'elemento del modulo


Nitro PDF Pro consente di modificare diverse proprietà degli elementi del modulo nella scheda Proprietà elemento modulo di Inspector. Il contenuto della finestra varia a seconda dell'elemento del modulo selezionato.

Per visualizzare, scegli Finestra > Proprietà elemento modulo o fai clic sulla scheda Modulo
inspector-form-elements-properties- 1
dell'Ispettore
ispettore
pannello se è già aperto.
forma-elementi-proprietà

Nome
Ogni elemento del form ha un nome per differenziarlo dagli altri.
Generalmente si utilizza un nome diverso per ogni campo. Un gruppo di pulsanti di opzione, tuttavia, dovrebbe avere ciascuno lo stesso nome ma un valore controllato diverso. Ciò consente loro di lavorare insieme (ad es. è possibile selezionare solo un pulsante in un gruppo) e ciascuno produce un risultato diverso.

Valore predefinito (campo di testo)
Imposta il testo che un utente vede nel campo di testo prima della compilazione del modulo. Una volta impostato il Valore di Default, noterai che non appare immediatamente nel campo di testo. Devi renderlo visibile scegliendo Modifica > Reimposta modulo.

Suggerimento per lo strumento
Crea etichette che descrivono ogni elemento del modulo. Le descrizioni comandi sono particolarmente utili per i campi modulo che necessitano di ulteriori chiarimenti oltre al nome del campo. Per testare, passa il mouse sopra il campo del modulo per visualizzare la descrizione comando. VoiceOver utilizza le descrizioni comandi (tagging di accessibilità efficace) per la descrizione dei campi del modulo.

Valore selezionato (pulsante di opzione, casella di controllo, pulsante di invio)
Questo è il valore ottenuto quando il pulsante di opzione o la casella di controllo associati è selezionato.

Limite di caratteri (campo di testo)
Selezionare questa opzione per impostare il numero massimo di caratteri che possono essere inseriti in un campo di testo.

Obbligatorio
Verificare se si desidera che questo campo del modulo venga compilato dall'utente. L'utente verrà avvisato quando tenterà di salvare il modulo i cui campi sono obbligatori ma non ancora compilati.

Taglia adatta (campo di testo)
Il campo di testo può aumentare o ridurre per adattarsi al testo immesso.

Multiriga (campo di testo)
Il campo di testo può contenere più di una riga di testo.

Scorri il testo (campo di testo)
Il campo di testo scorrerà orizzontalmente e/o verticalmente in una dimensione fissa in modo da poter inserire più del solo testo visibile.

Controlla per impostazione predefinita
Impostare una casella di controllo o un pulsante di opzione da selezionare prima che un utente compili il modulo. Una volta scelta questa opzione, noterai che non appare immediatamente sul modulo. Devi renderlo visibile scegliendo Modifica > Reimposta modulo.

Scelta in stile campo

Stile (casella di controllo, pulsante di opzione)
Seleziona un simbolo o uno stile di spunta che appare quando viene selezionata una casella di controllo o un pulsante di opzione. 

Per creare caselle di controllo o pulsanti di opzione con bordi, seleziona "Bordered". Per creare caselle di controllo o pulsanti di opzione senza bordi, deseleziona l'opzione "Bordered".

Nome e valore (campo di scelta, campo elenco)
Quando è disponibile un elenco di opzioni, ogni singolo elemento richiede un nome, il valore è facoltativo. Il nome verrà utilizzato come valore se non viene scelto un valore.

Etichetta, Opzioni di invio (pulsante Invia)
Imposta il titolo del pulsante di invio. Accedi alle opzioni di invio. Per ulteriori informazioni sull'invio dei moduli, vedere Elaborazione dei dati dei moduli .

Puoi modificare più proprietà contemporaneamente selezionando più campi modulo alla volta. Utilizzare i tasti Maiusc o Comando con lo strumento Modifica per selezionare più di un elemento.

Modifica dell'ordine delle schede

Nitro PDF Pro ti consente di modificare l'ordine di tabulazione degli elementi del modulo aggiunti a una pagina. Selezionare Disponi > Mostra ordine schede per visualizzare l'ordine delle schede all'interno di una pagina. Utilizzando le opzioni Disponi > Sposta, gli elementi del modulo selezionati verranno spostati avanti o indietro nell'ordine di tabulazione. Disponi > Ripristina ordine di tabulazione forzerà l'ordine di tabulazione degli elementi in una pagina all'ordine di lettura.

Modifica dell'ordine delle schede utilizzando la barra laterale

  1. Fare clic sul pulsante della barra laterale
    sidebar
    e scegli la visualizzazione Campi modulo
    vista-moduli-barra laterale
    .
  2. Un elenco dei tuoi campi apparirà nella barra laterale, trascina e rilascia per riordinare. L'ordine di tabulazione corrisponderà all'ordine degli elementi nell'elenco.

Calcoli campo modulo

PDFpenPro ti consente di creare campi modulo con calcoli personalizzati. I calcoli sono utili quando si desidera che i valori inseriti in campi specifici vengano calcolati automaticamente, ad esempio sommando il totale inserito in diversi campi precedenti, in un altro campo dello stesso documento.

Nota : per impostazione predefinita, i campi di testo creati in Nitro PDF Pro, automaticamente o manualmente, non dispongono di script. I JavaScript devono essere aggiunti manualmente ai campi.

Finestra degli script

La finestra Script di Nitro PDF Pro consente di visualizzare e modificare JavaScript esistenti, eliminare o aggiungere nuovi calcoli per i campi modulo.

  1. Usa lo strumento Modifica
    strumento di modifica
    (Comando+ 2 ) per selezionare il campo specifico che desideri modificare. I campi interattivi devono già esistere, o già aggiunti a una pagina, prima di poter essere modificati.
  2. Seleziona Finestra > Script.
  3. Gli script attualmente disponibili per il campo si rifletteranno nel riquadro di modifica. Il riquadro di modifica si trova sul lato destro della finestra Script. Fare clic all'interno del riquadro di modifica per modificare il JavaScript.
  4. Se non esistono ancora JavaScript per il campo selezionato, fare clic sul segno più + nell'angolo inferiore sinistro della finestra Script per aggiungere un nuovo script. Sostituisci il testo predefinito "// digita qui il tuo script" con uno script.
  5. Le modifiche apportate agli script verranno salvate automaticamente.

Calcoli e formattazione dei campi personalizzati

I calcoli possono essere semplici o avanzati. Esempi di semplici calcoli:

  • Somma
  • Prodotto
  • Media

Gli utenti possono anche definire la formattazione per campi specifici. Esempi di formattazione:

  • Percentuale
  • Codici di avviamento postale
  • Numeri di telefono
  • Numeri di previdenza sociale
  • Date

Quando si aggiungono nuovi calcoli, il Nome del campo si rifletterà nel riquadro elenco della finestra Script a sinistra. I nomi dei campi modulo vengono modificati in Proprietà elemento modulo . Affinché i calcoli funzionino, i nomi dei campi modulo in JavaScript devono corrispondere ai nomi dei campi attribuiti ai campi specifici in Proprietà elemento modulo.

Nota: la modifica e l'aggiunta di azioni modulo, formattazione, convalide o calcoli richiedono la conoscenza della programmazione JavaScript. Per ulteriori informazioni su JavaScript, inclusa la modifica, l'eliminazione e l'aggiunta di script a documenti, pagine e campi modulo, vedere Modifica e aggiunta di JavaScript .

Invio di PDF per firma elettronica (firma elettronica)

Per inviare documenti per le firme con i servizi di firma elettronica (firma elettronica) Nitro Sign o DocuSign®, vedere eSignature . I campi modulo possono essere assegnati e ulteriormente personalizzati per destinatari specifici nel servizio Nitro Sign o DocuSign.

Tag
Nitro PDF Mac Funzioni avanzate
Futuro del lavoro

Il Rapporto sulla produttività di Nitro 2022

Scopri come la pandemia ha trasformato la produttività, i flussi di lavoro e le iniziative digitali, nonché le tendenze e le tecnologie che plasmano il lavoro in 2022 e oltre.